Configure Network Package Repository

Hi,
How do I set up a network package repo?
If I add file:///server/directory to Package Manager, I get an error that it can’t find a repository at file:///C:/server/directory

1 Like

@benstreek it needs to be a network mapped drive, so use the syntax:

X:/server/directory

With ‘X’ being whatever drive you are using.

Thanks, @brennen_direnzo.
I can now see my packages in Package Manager.
It still doesn’t seem to be working for referencing packages in my .csproj file, though.

<OpenTapPackageRepository Include="file:///Z:\Software%20Development\OpenTAP\packages" />

gets me the following error in the output

message OpenTAP Install: PackageRepository : File package repository directory not found at: file:///Z:\Software Development\OpenTAP\packages

Also, are there any plans to support network locations without having to map them in future?

After a little more playing, it seems this isn’t related to it being a network location, using anything other than the official OpenTAP repo seems to fail. The only reason I thought other repos were working was because the packages happened to be in the package cache for my local installation.

Hi @benstreek,

I am not completely sure what is going wrong in your case, but maybe you can try installing the package from the command line? There you also have the option to disable the cache:

For example, this works for me to install packages from my Downloads folder:

tap package install [PackageName] --version beta -r "file://C:\Users\[User name]\Downlo
ads" --verbose --no-cache

Maybe you can try that as a first step?

OpenTAP: ^9.18.0
OS: Windows

Hi @benstreek,
I’ve had a similar experience, and it seemed to be related to the versions of tap.exe, packagemaager.exe, and OpenTAP.dll.
The only way I fixed it was by reverting back to 9.17.4 versions of everything, but I’ve also had a few issues with the licenses that may have contributed in some way.
@brennen_direnzo, could there be a conflict issue after 9.17.4 between using different versions of OpenTAP, tap.exe and packagemanager.exe? It’s very strange that it cannot locate packages on network drives, even if the fully qualified network path is mapped to a drive letter.
Using tap package list did not work either.
Could the wrong version of Keysight.OpenTap.Wpf.dll have an effect?

Update: Everything worked for a while using 9.18.4, but my licensing issues made me drop back to 9.17.4. I did this in a non-prescribed way that may have caused the version conflicts, where the plunging resolver may have picked up different versions.

@rolf_madsen and you have someone on the QA team look in to if there is an issue here?

1 Like

@brennen_direnzo, I am still not quite sure what the issue here is. I cannot reproduct it yet, so I hope getting some more info from @benstreek will help pinpointing it.

@jason.hicks, you should be able to just upgrade OpenTAP to e.g 9.19 and use 9.17 Editor as OpenTAP itself is not licensed.

1 Like

Cheers @rolf_madsen,
I’ll make an effort to update to the latest OpenTAP with 9.17.4 Editor in the next couple of weeks and let you know how I get on.

1 Like

Hi @rolf_madsen. Yeah, the command line works fine, so to clarify:
The project file has the following:

<OpenTapPackageRepository Include="file:///Z:\SoftwareDevelopment\OpenTAP\packages" />
<OpenTapPackageReference Include="PickeringCards" Version="any" />

The build fails.

I then add the package to my local OpenTap installation with

C:\Program Files\OpenTAP> .\tap package install PickeringCards --version any -r file:///Z:\SoftwareDevelopment\OpenTAP\packages

Which works fine and adds the package to the cache in %LOCALAPPDATA%

Running the build again then passes.

How about:
<OpenTapPackageReference Include="PickeringCards" Version="any" Repository="file:///Z:\SoftwareDevelopment\OpenTAP\packages"/>

That doesn’t work either, I’m afraid