SCPI Error from PXA

How can I prevent these from showing up as SCPI errors?

00:05:03.800029 ; PXA ; Debug ; SCPI >> SYSTem:ERRor?
00:05:03.800029 ; PXA ; Error ; SCPI << 64,“Align Now All required - DETECTED”
00:05:03.801954 ; PXA ; Debug ; SCPI >> SYSTem:ERRor?
00:05:03.801954 ; PXA ; Error ; SCPI << 1064,“Align Now All required - CLEARED”

When I have the PXA in a partial calibration mode I control the calibration routine through the entire test sequence. Annoyingly the Align Now events are seen as errors and rather than events.

@jason.hicks this is ultimately controlled by the instrument, so there isn’t anything to be done in OpenTAP to prevent it. You have to either:

  1. Continue to call SYST:ERR? To flush the queue until it returns “No Error”

  2. Or in TAP on your instrument settings you can disable error check, so this at least won’t be called every time.

Cheer man!

I’m not sure if I can sacrifice error checking for other commands. I suppose I could send SYSTem:ERRor? myself rather than rely on SCPI Instrument to do it.

1 Like

Right. Rather than automatically doing it after each step, you could call it explicitly.

Is there a way to progmatically disable error checking for a SCPI Instrument, or to disable the check box to prevent users enabling it?

In the Open method of your instrument you could call:

this.QueryErrorAfterCommand = false;

Once the instrument is opened, the settings are locked, so a user won’t be able to enable the checkbox.

1 Like