SCPI Query Timeout

Hi, did anyone face issue where using the ScpiQuery command will prompt a “Not responding (query ‘{0}’ timed out)” error message? It happened quite frequent. Can I set like a delay time to prevent the issue from happening?

I used the following function from the library:

Hi @keysightte ,

Have you tried increasing the IO Timeout setting?

1 Like