Error when updating to WPF 9.18.4

Hello everyone,

I’ve been having an issue with WPF 9.18.4 for months now. I have been avoiding thinking it is a generic problem and will be solved but i don’t see anyone else mentioning it so I guess I will need some help with that.

So, once I update WPF to latest version, I get an error “Caught unhandled GUI error” in the Logs and none of my Testplans is opened.

If I try to do so it will just show another entry to the Logs

Here are the logs.

SessionLog 2022-10-11 17-45-43.txt (14.6 KB)

I would appreciate any help. I do no have problem with updating other packages. Just this

Regards
CP

Hi connospp,
Looking at your Session Log, it seems some of your packages are still on 9.17.4. Try updating your “Developer’s System CE” package to 9.18.4 and see if this resolves your issue. You can do this through the Package Manager or the CLI.

Hello Ivan,

Thanks for taking interest to that.

There is no such a version available from CLI or Package manager.

By the way, keep in mind that because of that , I completely cleared up my user account and started fresh hoping something would change but it is still not helping

The problem is that you upgraded the WPF Controls package, but not the Editor packages. In theory there should not be breaking changes in the WPF Controls package, but apparently this occured between 9.17 and 9.18.

I recommend you downgrade the WPF Controls package to 9.17.4, then I think things should work again.

Yes, 9.17.4 does work that is correct.

However there has to be a way to upgrade. As I said, I did a reset on my PC and still cannot make it to work

As of now, 9.17.4 is the latest version for the CE package. We are working on releasing a new version.

Hence, not possible to update WPF controls?

No, not yet. the Community Version is behind the commercial version. Is there a a specific feature you are looking for?

This error occurred because of a breaking change between version 9.17.4 and 9.18 of WPF Controls. I don’t think @connospp, have any reason for updating except from the expectation that new versions should be an improvement over the old version.

In 9.19, we can fix this issue by re-adding the broken API and everybody should be happy… :slight_smile:

No, I am just looking to be compatible in case one of my customers is using am more up to date version.

Besides that I am good !

1 Like

@brennen_direnzo Is there any estimation on when the community package will be available? I’m looking for at least one feature introduced in 9.19 :slight_smile: