GUI error when add a test step in Editor CE with WFP controls 9.20.0

When I add any test step in Editor CE with WFP v9.20.0, I will get an GUI error show as below, but default version 9.17.4 worded well.

You should enable the Debug log-level and upload the log here.

SessionLog 2023-04-18 17-56-20.txt (455.6 KB)

Quick fix: downgrade WPF controls to a 9.17 version.

from the log it looks like the InformationBrush resource has been removed in a more recent version. We need to investigate when this happened and why we did not catch it.

@roz11, do you know if WPF controls 9.19 worked for you?

No, I have tried upgrade to each version , only 9.18 worked for me
neither 9.19 nor 9.20 worked

and, what’ more, I can’t open packagemanager when I installed v9.19 or v9.20, or uninstall WPF plugin with “tap package uninstall WPF”, the only way to solve this issue is uninstall OpenTAP 9 in ‘programs and feature’ and reinstall OpenTAP leave WPF with default version.

OK, I think you should be able to just do tap package install "WPF Controls" --version 9.17.

In any case, it is a bit unfortunate that you are stuck on version 9.17. We are working on fixing that, but for now it seems that is the only solution.